Thursday, 20 December 2012

Experimental H.264,AAC, and MP3 support in Firefox Nightly builds on Windows 7 and later

As the Internet has already discovered, recently I landed patches to add a Windows Media Foundation playback backend for Firefox. This is preff'd off by default.

This allows playback of H.264 video and AAC audio in MP4 and M4A files, and MP3 audio files in HTML5 <audio> and <video> elements in Firefox on Windows 7 and later.

To test MP4/MP3 playback, download the latest Firefox Nightly Build, and toggle the pref "media.windows-media-foundation.enabled" to "true" in about:config.

There are a few bugs that I'm aware of, which is why this landed preff'd off by default, but if you spot any bugs, please file a bug in Firefox's "Core :: Video/Audio" component.

7 comments:

The_Decryptor said...

Are there any plans to support the MKV container? Firefox already has some limited support for it via WebM, and trying to open an MKV file with H.264 content results in the video player opening, but then it reports an error saying it isn't supported.

Chris Pearce said...

No plans to support MKV at this time. Format proliferation doesn't help the web.

cleffy said...

You can install codecs for this. Then H.264 content in MKV works.

Chris Pearce said...

But even if you install codecs, MKV won't work on computers without the codec installed, which is most computers, and MKV won't work in other browsers. So web devs can't rely on MKV, so they won't use it.

jcreadytest said...

And MPEG support for Firefox on Mac will be arriving when?

Chris Pearce said...

I understand someone has expressed interest in doing the MP4 support in Firefox on Mac, but I'm not sure when they'll start and how long it will take.

Ken said...

Here is what I did to play YouTube videos without flash:
Firefox 20+ and Windows 7
set "media.windows-media-foundation.enabled" to true in about:config

Make sure Windows Media Center installed, follow this but turn on instead of off:
http://www.howtogeek.com/howto/15530/uninstall-disable-or-remove-windows-7-media-center/

Make sure you are not using the YouTube's "HTML5 Trial"
(to set this I disabled flash then right clicked on blank video and selected "about HTML 5")